CCNP_Switch コマンド集#2

CCNP_Switch コマンド集#2

・VLANの作成
(config)#vlan <VLAN番号>
(config-if)#name <VLAN名>

・アクセスポートの設定
(config-if)#switchport mode access
(config-ig)#switchport access vlan <VLAN番号>

・複数ポート指定
(config)#interface range <インターフェイス>

・トランクポートの設定
(config-if)#switchport trunk encapsulation <isl | dot1q>
(config-if)#switchport mode trunk

・ネゴシエーションの停止
(config-if)#switchport nonegotiate

・ネイティブVLANの設定
(config-if)#switchport trunk native vlan <VLAN番号>

・トランクポートで許可するVLANの設定
(config-if)#switchport trunk allowed vlan [add | none | expect | remove] <VLANリスト>

・VLANの設定確認
#show vlan [brief]

Switch1#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Et1/0, Et2/0, Et3/0, Et3/1
Et3/2, Et3/3
2 taskkun active
10 sales active Et0/1, Et0/2, Et0/3
20 It active Et1/1, Et1/2, Et1/3
30 Accounting active Et2/1, Et2/2, Et2/3
100 NativeVLAN active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

・トランクポートの設定確認
#show interfaces [<インターフェイス>] trunk

Switch1#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Et0/0 on 802.1q trunking 100

Port Vlans allowed on trunk
Et0/0 1,10,20,30

Port Vlans allowed and active in management domain
Et0/0 1,10,20,30

Port Vlans in spanning tree forwarding state and not pruned
Et0/0 1,10,20,30

・ポートの設定確認
#show interfaces [<インターフェイス>] switchport

Switch1#show interfaces ethernet 0/0 switchport
Name: Et0/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 100 (NativeVLAN)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 1,10,20,30
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Appliance trust: none

Switch1#show interfaces ethernet 0/1 switchport
Name: Et0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (sales)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Appliance trust: none

・VTPモードの設定
(config)#vtp mode <server | client | transparent>

・VTPドメイン名の設定
(config)#vtp domain <VTPドメイン名>

・VTPパスワードの設定
(config)#vtp password <VTPパスワード>

・VTPバージョンの設定
(config)#vtp version <バージョン>

・VTPプルーニングの設定
1台のサーバーモードのスイッチで入力するとドメイン内の他のスイッチでも有効になる。
(config)#vtp pruning

・VTPプルーニングの設定確認
#show interfaces [<インターフェイス>] pruning

L3Switchルーティング
・SVIの作成
(config)#interface vlan <VLAN番号>

・自動ステート除外機能の設定
(config-if)#switchport autostate exclude

・ルーテッドポートの作成
(config-if)#no switchport

・スイッチポートに変更
(config-if)#switchport

・スイッチポートの確認
#show interfaces [<インターフェイス>] switchport

Switch1#show interfaces ethernet 0/1 switchport
Name: Et0/1
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Appliance trust: none

・MACアドレスフィルタリングのACL作成
(config)#mac access-list extended <ACL名>
(config-ext-nacl)#permit <送信元MACアドレス> <ワイルドカードマスク> <宛先MACアドレス> <ワイルドカードマスク> [オプション]

・RACLの適用
ルーテッドポートやSVIに適用
(config-if)#ip access-group <ACL番号 | ACL名> <in | out>

・PACLの適用
スイッチポートに適用
(config-if)#ip access-group <ACL番号 | ACL名> <in | out>
(config-if)#mac access-group <ACL番号 | ACL名> <in

・VLANアクセスマップの作成
(config)#vlan access-map <VLANアクセスマップ名> [<シーケンス番号>]
(config-access-map)#match <ip | mac> address <ACL番号 | ACL名>
(config-access-map)#action <forword | drop>

※最後にすべての通信を破棄する処理が入る。
※VLANアクセスマップのACLのpermitは許可の意味ではなくactionの対象となるかどうかを示す。

・VACLの適用
複数のVLANを指定可
(config)#vlan filter <VLANアクセスマップ名> vlan-list <VLAN番号>

CCNPカテゴリの最新記事

%d人のブロガーが「いいね」をつけました。
TOP